GLOBAL KNOWLEDGE NETWORKä CERTIFICATION PRESS
Cisco Certified Network Associate Exam
Router and Switching Study Guide

 

Chapter 6 IP Configuration

BOOK TABLE OF CONTENTS

SELF TEST

RETURN TO HOME PAGE

 

 

Certification Objectives *

Method *

Router 1 *

Router 2 *

Router 3 *

Router 1 *

Router 2 *

Router 3 *

From the Classroom *

Changing Traffic Flow with IGRP *

DNS Configuration *

Forwarding DHCP Requests *

Router 1 *

 

 

 

Certification Objectives

TCP/IP is the most prevalent network protocol in use today. Virtually any LAN you will manage or even build has some facet revolving around IP, if not entirely based on it. Whether or not you have the luxury of starting from scratch on your network is irrelevant. This chapter will explain the configuration of IP, from an interface level to interconnectivity between routers. For the interface, it will detail assigning IP addresses and configuring DNS lookups, DHCP, and host tables. For interconnectivity, it will outline the basic configuration of RIP and IGRP routing, and explain how to set up static and default routes.

IP Configuration Commands

Configuration of IP takes place on a per-interface basis. To set the primary IP address and subnet mask to an interface, enter its configuration mode and type the command:

Ip address ip-address mask

Note it is possible to add more IP addresses to interfaces, but this will be covered in the last section of this chapter.

{Answer to Self Test Question #21}There are some circumstances in which you might want to enable IP across an interface without having to assign an explicit IP address. This functionality is available exclusively on Cisco routers and is called IP unnumbered. {Answer to Self Test Question #35} It is used on point-to-point links where the same subnet mask is being used on both sides of the connection. It works by allowing communication to occur across the connection via the Ethernet interfaces, with the benefit of not having to allocate an entire subnet for the link. IP unnumbered is configured on a per-interface basis. The following is an excerpt from the configuration of a router running with an unnumbered interface.{Answer to Self Test Question #7}

interface ethernet0

ip address 10.10.10.45 255.255.255.0

!

interface serial1

ip unnumbered ethernet 0

Configuring Static Routes

{Answer to Self Test Question #9} , {Answer to Self Test Question #22}Routes between network segments sometimes have to be added manually. There are several advantages that static routes have over dynamic routes. One advantage is that there is less overhead for the router, since it doesn't have to perform calculations on the fly and send out router updates. Another advantage of using static routes is that the paths between two destinations are always known, and this helps reduce the number of places where faults can lie.

Of course, with advantages there are always going to be disadvantages. One of the obvious drawbacks to static routing is its lack of scalability. From the looks of the example in Figure 6-1, it would appear that static routing is pretty easy to implement. This is true when you are only talking about a handful of network segments. Imagine, though, if you had 50 network segments inter-connected with about 25 routers! The overhead involved to enter all of those routes would be tremendous.

{Answer to Self Test Question #1} , {Answer to Self Test Question #23}If a router learns a route to a network from more than one source, it uses a ranking called administrative distance to determine which one to place in its IP routing table. All routes, whether dynamic or static, are assigned an administrative distance. The route with the lowest value will be used. The default administrative distances for some of the more common routing methods are listed in Table 6-1.{Answer to Self Test Question #15}, {Answer to Self Test Question #36}

Method

Administrative Distance

Directly Connected

0

Static

1

EIGRP

90

IGRP

100

OSPF

110

RIP

120

Table 1 Default Administrative Distances

Routes are added with the IP ROUTE command. This is done as a global configuration, since routes are not dependent on an interface.

To understand how static routes are implemented, look at the example in Figure 6-1. The configuration for each router is listed following the example.

 

Figure 1 Static routes

Router 1

Router1#wr t

Building configuration...

Current configuration:

!

Version 11.1

!

hostname router1

!

enable secret 5 $1$F4Sds42cRfAK204jKLIFNO$Mpruh.

Enable password mayo

!

interface ethernet0

ip address 10.10.10.1 255.255.255.0

!

interface ethernet1

ip address 10.10.20.1 255.255.255.0

!

ip route 10.10.30.0 255.255.255.0 10.10.20.2

ip route 10.10.40.0 255.255.255.0 10.10.20.3

!

line con 0

line aux 0

transport input all

line vty 0 4

password vbm

login

!

end

Router 2

Router2#wr t

Building configuration...

Current configuration:

!

Version 11.1

!

hostname router2

!

enable secret 5 $1$F4Sds42cRfAK204jKLIFNO$Mpruh.

Enable password mayo

!

interface ethernet0

ip address 10.10.20.2 255.255.255.0

!

interface ethernet1

ip address 10.10.30.1 255.255.255.0

!

ip route 10.10.10.0 255.255.255.0 10.10.20.1

ip route 10.10.40.0 255.255.255.0 10.10.20.3

!

line con 0

line aux 0

transport input all

line vty 0 4

password vbm

login

!

end

Router 3

Router3#wr t

Building configuration...

Current configuration:

!

Version 11.1

hostname router3

!

enable secret 5 $1$F4Sds42cRfAK204jKLIFNO$Mpruh.

Enable password mayo

!

interface ethernet0

ip address 10.10.20.3 255.255.255.0

!

interface ethernet1

ip address 10.10.40.1 255.255.255.0

!

ip route 10.10.10.0 255.255.255.0 10.10.20.1

ip route 10.10.30.0 255.255.255.0 10.10.20.2

!

line con 0

line aux 0

transport input all

line vty 0 4

password vbm

login

!

end

Configuring Default Routes

As I'm sure you can imagine, in large networks and internetworks every router cannot know the exact route to every other router. This is where the default route is useful. The default route specifies where to send non-local packets. The router assumes that it can send the packet to the default router, and that router will know what to do with it. This feature is only used when IP routing is disabled. It is typically only used in "stub" networks, where there is only a single link to the rest of the internetwork. If the next router doesn't know the necessary route, it sends the packet to its own default route, and this process continues on until the destination network is reached. Configuration of the default route is performed with the following command:

Ip default route ip address{Answer to Self Test Question #13}

You can view the address of the current default route by entering:
show ip route
{Answer to Self Test Question #3}

Configuring RIP Routing

{Answer to Self Test Question #24}The enabling of RIP is performed at the global level, but a lot of the configuration can be performed on a per-interface basis. You can enable or disable RIP by entering the following command.

[no] router rip

{Answer to Self Test Question #26} {Answer to Self Test Question #6}All timing issues regarding how often RIP updates are performed and how long before they are either stored or removed from tables can be configured with the timers basic command.

timers basic update invalid holddown flush [sleeptime]

{Answer to Self Test Question #25} RIP updates are sent, by default, every 30 seconds. This number can be changed through the UPDATE argument. When no update is received from a route after a specified amount of time, the route is declared invalid. This amount of time, in seconds, is set with the INVALID argument. This number is typically three times the period set for the sending of RIP updates. Now when the route becomes invalid, it enters a holddown period, which is the next argument to configure. During the holddown period the router will not allow information regarding other paths to be added. When it is in the holddown period the route acts like it is inaccessible, but it will still be used for forwarding packets. This is also specified in seconds. The final setting, FLUSH, specifies the amount of time that must expire before it flushes the route from its routing table. This is also specified in seconds and must be, at minimum, equal to the summation of INVALID and HOLDDOWN. The last setting is for IGRP use only and will be discussed in the next section of this chapter.

Configuring IGRP Routing

{Answer to Self Test Question #4} , {Answer to Self Test Question #27} , {Answer to Self Test Question #28}The basic configuration of IGRP is a pretty straightforward process. First, you need to assign an autonomous system number to the IGRP process. The autonomous system number allows other routers that use the same number to exchange route information. This is followed by telling the router which directly connected networks it should advertise its initial IGRP packet on. Look at the diagram listed in Figure 6-2, and at each router's configuration.

Figure 2: IGRP routing

Router 1

Router1#wr t

Building configuration...

Current configuration:

!

Version 11.1

hostname router1

!

enable secret 5 $1$F4Sds42cRfAK204jKLIFNO$Mpruh.

Enable password mayo

!

interface ethernet0

ip address 10.10.10.1 255.255.255.0

!

interface ethernet1

ip address 10.10.20.1 255.255.255.0

!

router igrp 7

network 10.0.0.0

!

line con 0

line aux 0

transport input all

line vty 0 4

password vbm

login

!

end

Router 2

Router2#wr t

Building configuration...

Current configuration:

!

Version 11.1

hostname router2

!

enable secret 5 $1$F4Sds42cRfAK204jKLIFNO$Mpruh.

Enable password mayo

!

interface ethernet0

ip address 10.10.20.2 255.255.255.0

!

interface ethernet1

ip address 10.10.40.1 255.255.255.0

!

router igrp 7

network 10.0.0.0

!

line con 0

line aux 0

transport input all

line vty 0 4

password vbm

login

!

end

Router 3

Router3#wr t

Building configuration...

Current configuration:

!

Version 11.1

hostname router3

!

enable secret 5 $1$F4Sds42cRfAK204jKLIFNO$Mpruh.

Enable password mayo

!

interface ethernet0

ip address 10.10.10.2 255.255.255.0

!

interface ethernet1

ip address 10.10.30.1 255.255.255.0

!

router igrp 7

network 10.0.0.0

!

line con 0

line aux 0

transport input all

line vty 0 4

password vbm

login

!

end

From the Classroom

Changing Traffic Flow with IGRP

The fact that IGRP uses a cost metric to make routing decisions gives us an opportunity to manipulate those decisions in a way that is not possible with RIP. We can't change the number of hops an interface is worth, and we can't change the IGRP cost directly, but there is an interface parameter we can play with-bandwidth-that figures into the algorithm for calculating the cost of a path.

Many students are surprised to find out that changing the bandwidth parameter on an interface has nothing to do with the actual speed of data transmission over that link. The router has no way to measure the actual speed of the serial link, so this parameter has a default value, which is equivalent to a T1 bandwidth. If your network's serial links are all identical in terms of bandwidth, this won't be a problem for you. On the other hand, if you have a variety of links with varying bandwidths, you will probably want to make this value reflect the actual bandwidths of those links in order for IGRP to give you optimal routing. The interface configuration command to do this is BANDWIDTH, which takes one argument, an integer representing thousandths of bits per second. You should see the effect in the output of the show interface serial command.

If you don't care about optimal routing, or if for some reason (such as monetary cost) you just need to make traffic flow another way, you can make the bandwidth appear to be very low on the less desirable links and very high on the most desirable links, in order to fool the IGRP routing protocol. Again, changing the bandwidth parameter has absolutely no effect on actual speed of transmission. In a production network you would be getting your clocking from the provider's network. In a lab situation, the DCE end of the link would be configured with the CLOCK RATE command.

-Pamela Forsyth, CCIE, CCSI, CNX

IP Host Tables

As I'm sure you're aware from using the Internet, IP addresses typically have host names mapped to them. If you wish to access a site, you can enter the name associated with that particular location instead of having to remember a string of numbers. It is much easier to remember mylocation.com rather than 10.20.14.83.

{Answer to Self Test Question #19}, {Answer to Self Test Question #29}Cisco routers keep a table of host name-to-address mappings in their host cache. Entries can be added and removed with the IP HOST command. When issuing this command you can optionally assign a TCP port number to use when establishing a connection. The default is the Telnet port 23. You can then bind multiple IP addresses to the host name, up to a maximum of eight. {Answer to Self Test Question #2}

ip host name [tcp-port-number] address1 [address2-address8]

[no] ip host name address1

DNS and DHCP Configuration

{Answer to Self Test Question #16}The capability to dynamically look up host name-to-address mappings is a feature of Domain Name Service (DNS). This is used for connectivity with devices in networks where you don't control the name assignments. Dynamic Host Configuration Protocol (DHCP) is used for the dynamic distribution of IP addresses to client machines. Cisco routers have the capability to forward DHCP requests across different subnets. The following sections will outline each of these features.

DNS Configuration

DNS capability is enabled by default in the Cisco IOS, but if it is disabled it can be re-enabled with the following command.

Ip domain-lookup

{Answer to Self Test Question #30}To enable DNS lookups, you should tell the router where the name servers that it is to use for lookups are located. If you do not specify them, a broadcast DNS request will be made by the router. The advantage to manually specifying them is to cut down on the broadcast requests being transmitted. You have the ability to add up to six with the command: {Answer to Self Test Question #5}

Ip name-server server1 {server 2...server 6}

Where server1, server 2, etc. are IP addresses of the servers, not the host names.

You can also specify the default domain that the IOS will use to complete the domain name requests. What this does is allow IOS to add requests that are not fully qualified domain names in domains you frequently access. I say "domains" (plural) because you have the ability to make multiple listings. By stating the default, the domain name you specify is appended to the host name before being added to the host table in the cache.

To specify a single domain, enter the following.

Ip domain-name name{Answer to Self Test Question #10}

To specify a list of default domains to use, enter the following.

Ip domain-list name

Cisco also supplies a way to use the DNS to discover International Organization for Standardization Connectionless Network Service (ISO CLNS) addresses. This feature is used when your router has both IP and ISO CLNS enabled and you want to use ISO CLNS network service access point (NSAP) address. DNS has the capability to query these by default. This option is configured globally.

[no] ip domain-lookup nsap

Forwarding DHCP Requests

{Answer to Self Test Question #11},{Answer to Self Test Question #31}By default Cisco routers (or any router for that matter) will not forward broadcast-based traffic. One type of broadcast traffic is User Datagram Protocol (UDP) packets. If you wish to forward UDP-type traffic, you need to add the host address in an IP helper-address statement. A helper-address statement will forward selected protocols received on that interface to the specified host address. When you invoke the IP helper-address statement, UDP packets from the certain ports will be forwarded by default, as described in Table 6-2.

Protocol

Familiar Name

Port

Trivial File Transfer Protocol

TFTP

69

Domain Name Service

DNS

53

Time Service

-

37

NetBIOS Name Server

-

137

NetBIOS Datagram Server

-

138

Boot Protocol (Client and Server)

BOOTP

67 and 68

TACACS

TACACS

49

Table 2 Protocol and Port Numbers {Answer to Self Test Question #12}

{Answer to Self Test Question #17}If you wish to select other protocols to forward, you can use the ip forward-protocol command. DHCP uses UDP for its transport, and uses the BOOTP protocol for its operation. DHCP information is encapsulated within BOOTP datagrams. The following example lists the configuration found in Figure 6-3. Even though BOOTP packets are forwarded by default after invoking the helper-address command, I chose to specify the BOOTP ports anyway, to show an example of implementing the IP FORWARD command.

Figure 3 DHCP

Router 1

Router1#wr t

Building configuration...

Current configuration:

!

Version 11.1

hostname router1

!

enable secret 5 $1$F4Sds42cRfAK204jKLIFNO$Mpruh.

Enable password mayo

!

interface ethernet0

ip address 10.10.10.1 255.255.255.0

!

interface ethernet1

ip address 10.10.20.1 255.255.255.0

ip helper-address 10.10.10.101

!

ip forward-protocol udp 67

ip forward-protocol udp 68

!

line con 0

line aux 0

transport input all

line vty 0 4

password vbm

login

!

end

There are a couple of things to note about the IP helper-address command. The command is placed on the interface where it will hear the client's broadcast request. When the broadcast is forwarded, it is changed by the router to the address specified in the IP helper-address command. If that address is a host address, the request will be forwarded as a unicast. If it is a directed broadcast address, it will be forwarded as a directed broadcast.

{Answer to Self Test Question #18}Another thing to notice in the preceding example is that the forwarding of UDP is performed at a global level. Also, if you have a situation where you want to prevent a protocol from being forwarded from only one interface, you will have to build an access list and apply it to the interface. Configuration of access lists will be covered later in this book.

Secondary Addressing

{Answer to Self Test Question #20} , {Answer to Self Test Question #32}, {Answer to Self Test Question #33}, {Answer to Self Test Question #34}Along with the normal IP addressing you are familiar with, the Cisco IOS also supports adding multiple secondary addresses to single interfaces. To understand the benefit of this, imagine this scenario: Let's say we are implementing a Class C addressing scheme, where there are 254 host IDs available. Our company expands, and we are now to the point where we need to accommodate 350 users, and they all need their own IP addresses. To avoid adding more hardware, we can assign a secondary IP address on the outgoing router to allow two logical subnets across the same physical interface. We can now split the 350 users across the two subnets, at no additional cost.

If you decide to implement secondary addressing on a router, you should remember that all other routers that attach to the same physical subnet as the one that has the secondary address will also need a secondary address on that same subnet. The reason for this is as follows. Look at the example shown in Figure 6-4. We have two users who are on different logical subnets, but are connected to the same physical interface. We are implementing a secondary address only on Router A. With the situation that is listed, both User 1 and User 2 will be able to reach Server A, since it Router A knows of both subnets on E1. However, if both users wish to connect to Server B, only User 1 will be able to reach it. This is because Router B has no idea about the 10.10.20.0 network that it should have access to on E0.{Answer to Self Test Question #14}

Figure 4 Secondary Addressing 1

To apply a secondary address, you use the same syntax as assigning a primary address to an interface, except you end it with the SECONDARY argument.

Ip address ip-address mask secondary{Answer to Self Test Question #8}

Here are some sample IP configuration problems such as you might encounter on the CCNA exam, or in your work.

I entered a static route that I want to use as a last resort. We are using OSPF, but currently my route takes precedence over OSPF entries. How do I change the configuration?

Change the administrative distance for your static route to any number above 110, which is OSPF's default.

I am running RIP across a 64-kbps WAN link. The updates are taking up too much bandwidth. What should I do?

Change the update period to a slower amount than the default 30 seconds.

How do I get my workstations to receive their IP addresses via DHCP on a different subnet than the DHCP server?

On the router that connects the two network segments, enter an IP helper address and point it to the DHCP server.

We are using Internet-assigned IPs and are running low on the ones left in our range. We are adding another remote site, and we can't afford to waste an entire subnet. What should we do?

Use IP unnumbered on the two ends of the point-to-point link.

We just added 26 more users on a segment to bring the total to 262 hosts. Am I going to have to add another router to accommodate the new people?

No. Use a secondary IP address on the interfaces connecting each end of the segment.

 

 

Certification Summary

Implementing static routes is advantageous in small networks and in situations where you need to cut down on the amount of processing being performed by the router. Dynamic routing is more suited for larger networks that require something more scalable and that don't require as much overhead. Routers may learn routes from a variety of sources: their directly connected interfaces, static routes configured by an administrator, or from many dynamic IP routing protocols. If the router learns routes to a network from more than one source, it will use the one with the smallest administrative distance.

RIP is the easiest dynamic routing protocol to implement. Its updates are sent out by default every 30 seconds, but this is configurable with the TIMERS BASIC command. IGRP is a more efficient routing protocol that uses autonomous system numbers to distinguish which routers are to communicate with which others.

Dynamic lookup of host name-to-address mappings can be performed with DNS. DNS is enabled by default on Cisco routers, and you can specify up to six name servers to use. Cisco also supports relaying DHCP requests across subnets. DHCP is a UDP-type packet that is encapsulated within BOOTP. You can enable this functionality with the ip helper-address command.

Two-Minute Drill

 

 

 

 

 

Self Test

  1. What is the administrative distance for directly connected routes?
    1. 0
    2. 1
    3. 100
    4. 120

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    A. Directly connected routes have an administrative distance of 0.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  2. How many IP addresses can be bound to each host name using the IP HOST command?
    1. 1
    2. 2
    3. 8
    4. 255

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    C. Each host address can have a maximum of eight IP addresses.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  3. Which command do you use to view the currently configured default route?
    1. show ip config
    2. show default gateway
    3. show ip route
    4. show default network

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    C. Show IP route is the command for viewing the current default route.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  4. Which routing protocol uses autonomous system numbers?
    1. RIP
    2. IGRP
    3. OFLP
    4. OSPF

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    B. IGRP uses autonomous system numbers to identify separate IGRP processes.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  5. How many DNS servers can be added to a router's configuration?
    1. One
    2. Two
    3. Four
    4. Six

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    D. You can add six DNS servers with the IP NAME-SERVER command.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  6. When configuring IGRP, what is the minimum amount for the FLUSH argument in the TIMERS BASIC command?
    1. 30 seconds
    2. Three times the period set for sending RIP updates
    3. The summation of INVALID and HOLDDOWN
    4. UPDATE minus SLEEPTIME

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    C. FLUSH must be the summation of INVALID and HOLDDOWN at minimum.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  7. Which of the following is not true regarding IP unnumbered?
    1. Major drawback is the loss of an IP subnet
    2. IP unnumbered is only available on Cisco routers
    3. Can be used to communicates across serial interface through Ethernet interface
    4. Used on point-to-point links

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    A. The advantage of IP unnumbered is that it prevents the loss of an entire subnet by not requiring the assignment of IPs to the two routers' serial interfaces.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  8. Identify the proper syntax for assigning a secondary IP address to an interface.
    1. Ip secondary address 10.10.10.10 255.0.0.0
    2. IP 10.10.10.10 255.255.0.0 secondary
    3. IP address secondary 10.10.10.10 255.255.255.0
    4. IP address 10.10.10.10 255.255.255.0 secondary

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    D. The correct syntax is IP ADDRESS ip-address mask SECONDARY, therefore IP ADDRESS 10.10.10.10 255.255.255.0 SECONDARY would be correct.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  9. Which of the following are advantages to static routing?
    1. Less overhead on router
    2. Paths are created on the fly
    3. Reduction in places where faults can lie
    4. Scalable

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    A, C. The advantages to static routing are that it creates less overhead on routers, and reduces the number of places where faults can lie. There are more actions that take place in dynamic routing, so more needs to be investigated to find problems.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  10. What does the IP DOMAIN-NAME command do?
    1. Names the domain that the Cisco router belongs to
    2. Names domains the router cannot find directly
    3. Appends a domain to unqualified requests
    4. Broadcasts domain name across subnets

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    C. The IP DOMAIN-NAME command will append the domain listed to unqualified domain requests in order to try to find a fully qualified host name.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  11. By default, what happens to broadcast UDP packets that come across Cisco routers?
    1. They are denied
    2. They are converted into broadcast-based packets
    3. They are routed to all IP interfaces
    4. They are sent to UDP queues

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    A. By default, all broadcast UDP packets are denied.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  12. What are the default ports for BOOTP traffic?
    1. 23 and 24
    2. 67 and 68
    3. 138 - 141
    4. 9 and 10

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    B. The default ports for BOOTP traffic are 67 and 68.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  13. Which syntax for setting the default gateway is correct?
    1. IP default-gateway 10.10.10.100
    2. IP 10.10.10.100 default-gateway
    3. Default-gateway 10.10.10.100 255.255.255.0
    4. IP default-gateway 10.10.10.100 255.255.255.0

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    A. The correct syntax is IP default-gateway ip-address, therefore IP default-gateway 10.10.10.100 would be correct.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  14. Which is true regarding secondary addressing?
    1. Secondary addressing must exist on the same subnet as the primary
    2. Secondary addressing can only be applied to serial interfaces
    3. A maximum of three address can be assigned per interface
    4. All attached routers need a secondary address on same subnet

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    D. All directly attached routers need a secondary address on the same subnet as the referenced router.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  15. Which of the following statements about administrative distance are true?
    1. It is used when two routing protocols advertise the same route
    2. All routes have an administrative distance
    3. The lowest value always wins
    4. Static routes have an administrative distance of 1

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    A, B, C, D. All these statements are correct. When two routing protocols advertise the same route, the administrative distance is used. All routing protocols have a default value, and the route with the lowest value will win and be added to the cache. Static routes have an administrative distance of 1, while directly connected routes have an administrative distance of 0.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  16. Which of the following acronyms is not accurate?
    1. DNS - Dynamic Naming Service
    2. UDP - User Datagram Protocol
    3. DHCP - Dynamic Host Configuration Protocol
    4. TFTP - Trivial File Transfer Protocol

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    A. DNS stands for Domain Name Service.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  17. Where can DHCP information be found?
    1. Encapsulated within UDP packets
    2. Encapsulated within the TCP part of TCP/IP
    3. Encapsulated within BOOTP packets
    4. Encapsulated within DNS traffic

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    C. DHCP information is contained in the data portion of BOOTP packets

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  18. Which of the following is performed at a global level?
    1. Forwarding of UDP
    2. DNS lookup
    3. Adding routes
    4. Enabling RIP

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    A, B, C, D. The forwarding of UDP packets, DNS lookup, adding routes, and enabling RIP are all done at the global level.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  19. Where are the host name-to-address mappings stored?
    1. Address cache
    2. Host cache
    3. Static RAM
    4. IP Config table

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    B. The table of host name-to-address mappings is stored in the host cache.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  20. If you add more users than there are available host addresses on a given subnet, which of the following principles can you apply to remedy the situation?
    1. IGRP
    2. Shared IP
    3. Secondary addressing
    4. IP unnumbered

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    C. Secondary addressing is what you use to assign multiple IP addresses to single interfaces. Adding a second IP address to a NIC enables you to add another subnet to the physical segment, thereby increasing your number of available hosts.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  21. An ip unnumbered command does which of the following?
    1. It allows use of different subnet masks on two ports on each side of the link
    2. It is used in a point-to-multipoint configuration
    3. It allows the same netmask number to be used on each side of the link
    4. It makes an effective use of IP addresses

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    C, D. The ip unnumbered command allows the same netmask to be used on either side of the link, thus minimizing the waste of IP addresses. It also uses your available IP addresses effectively, since it prevents you from wasting an entire subnet across the link.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  22. In static routing, the route to a destination network:
    1. Is not known prior to configuration
    2. Remains permanently in the routing table
    3. Is determined in real time
    4. Is known prior to configuration

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    D. In static routing, the path between two destinations is known prior to configuring a router.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  23. If two routing protocols recommend the same route to a router, the router will:
    1. Select either of the two routes at random, with no preference for one over the other
    2. Select the route that has a lower administrative distance value
    3. Select the route that has a higher administrative distance value
    4. Place both the routes in the routing table

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    B. The router will select a route associated with the protocol that has the lower administrative distance value.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  24. What is the command used to remove static routes from the routing tables?
    1. show ip route
    2. show ip redirect
    3. change ip route
    4. no ip route

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    D. The no ip route command removes static routes from the routing tables.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  25. What is the default time interval at which RIP updates are sent?
    1. 30 seconds
    2. 15 seconds
    3. 60 seconds
    4. 90 seconds

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    A. RIP updates are sent every 30 seconds unless specified otherwise.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  26. In the timers basic command, the parameter to specify the time after which the route is to be taken out from the routing table is:
    1. sleeptime
    2. holddown
    3. invalid
    4. flush

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    D. Flush tells the router to take the entry out of the routing table after a certain time.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  27. In an IGRP command timers basic 15 45 0 60, the number 45 represents:
    1. holddown time
    2. update time
    3. invalid time
    4. flush time

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    C. The number 45 represents the invalid time. The invalid time represents time at which the route becomes invalid and is typically set at three times the value of the update parameter (15 sec in this case is update parameter).

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  28. In an IGRP command router igrp 7, the number 7 is:
    1. An autonomous system number
    2. A gateway number
    3. A port number
    4. A terminal number

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    A. The number 7 is an autonomous system number.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  29. In the command ip mynetwork 132.2.2.2, what port number is used in establishing a connection?
    1. 21
    2. 23
    3. 25
    4. 69

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    B. When no port is specified, a default port number of 23 is used for Telnet.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  30. In Cisco routers the DNS lookup capability must be enabled.
    1. True
    2. False

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    B. In Cisco routers the DNS capability is enabled by default. If it has been disabled, then an enable command is needed.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  31. In order to forward broadcast traffic for certain UDP requests, which of the following commands should be used?
    1. ip helper-address
    2. ip address
    3. ip forward-protocol
    4. interface
    5. A and C only
    6. B and C only

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    E. The IP HELPER command identifies the network where the broadcasts are to be directed, and the IP FORWARD command tells the router that it needs to forward the packets sent by UDP.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  32. What is the purpose of secondary addressing?
    1. To increase the number of hosts on the same network by increasing the IP address capacity
    2. To increase the number of subnets
    3. To limit hardware cost
    4. A and B only
    5. B and C only
    6. A and C only

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    F. Secondary addresses are used to add hosts on a network without adding additional hardware.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  33. If we implement a secondary address on router X, and we need all other routers to be able to route traffic to its attached hosts, all other routers attached to the same physical subnet as router X will also need a secondary address on the same subnet.
    1. True
    2. False

     

    CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    A. True. All other routers attached to the same physical subnet as router X will also need a secondary address on the same subnet.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  34. The secondary address configuration can be achieved by applying the identical set of commands that are used for configuring the primary address.
    1. True
    2. False

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    B. False. For configuring secondary addresses, a secondary parameter is required at the end of the command.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  35. IP unnumbered is configured:
    1. Globally for all interfaces
    2. On each interface as needed
    3. On serial interfaces only
    4. On Ethernet only

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     


    B. IP unnumbered is configured on one interface at a time.

     

     CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

     Exit and Return to Home Page

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  36. Match the protocol on the left with administrative distances on the right.
    1. static 1. 120
    2. OSPF 2. 100
    3. RIP 3. 1
    4. IGRP 4. 110

 

 CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

 Exit and Return to Home Page

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


A-3, B-4, C-1, D-2 See Table 6-1 for information on administrative distances.

 

CCNA Routing and Switching Study Guide: Self Test for Exam 640-407

 Exit and Return to Home Page